Home Forum Statistica con R Ultimo aggiornamento R Studio

This topic contains 2 replies and has 2 voices.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4620

    mattiaporta
    Participant

    Ciao a tutti. Mi chiamo Mattia e sono uno studente di Economia all’ Università di Cagliari. È la prima volta che scrivo. Sto cercando di installare questo package ( https://CRAN.R-project.org/package=ISLR) per una regressione logistica, ma mi dice che questo “pacchetto” non è disponibile per l’ultima versione di R. Sotto alcune linee della schermata:

    > install.packages(“https://CRAN.R-project.org/package=ISLR”)
    Installing package into ‘C:/Users/matti_000/Documents/R/win-library/3.2’
    (as ‘lib’ is unspecified)
    Warning in install.packages :
    package ‘https://CRAN.R-project.org/package=ISLR’ is not available (for R version 3.2.3)

    Sapete se c’è un modo per aggiornare il package o qualche alternativa per poterci lavorare, oppure non è possibile installarla.

    Grazie in anticipo

    • This topic was modified 7 months, 1 week ago by  mattiaporta.
    • This topic was modified 7 months, 1 week ago by  mattiaporta.
    #4623

    Ciao Mattia,
    io sono riuscito ad installare con successo questa libreria. Penso il problema sia nel come chiami la libreria quando cerchi di installarla. Invece di fare questa operazione:

    
    > install.packages("https://CRAN.R-project.org/package=ISLR")
    Warning message:
    package ‘https://CRAN.R-project.org/package=ISLR’ is not available (for R version 3.3.0) 
    

    prova così:

    
    > install.packages("ISLR")
    --- Please select a CRAN mirror for use in this session ---
    provo con l'URL 'https://cran.stat.unipd.it/bin/macosx/mavericks/contrib/3.3/ISLR_1.0.tgz'
    Content type 'application/octet-stream' length 2914144 bytes (2.8 MB)
    ==================================================
    downloaded 2.8 MB
    
    The downloaded binary packages are in
    	/var/folders/21/r7l1lxld5rd3dy8dg91b75280000gn/T//RtmpadUJtx/downloaded_packages 
    

    In generale quando installi una libreria con install.packages() dovresti inserire solo il nome non un file path (a meno che l’argomento repos=NULL)

    #4624

    mattiaporta
    Participant

    Ciao Francesco,

    sono riuscito a risolvere con il tuo aiuto, grazie mille.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.