Home Forum Fuoritema Problema istallazione pacchetto "RecordLinkage"

Questo argomento contiene 0 risposte, ha 1 partecipante, ed è stato aggiornato da  sofia lon 3 settimane, 5 giorni fa.

Stai vedendo 1 articolo (di 1 totali)
  • Autore
    Articoli
  • #7527

    sofia lon
    Partecipante

    Ciao a tutti, sono alla disperata ricerca di aiuto. Non riesco a istallare il pacchetto RecordLinkage mi da questo errore:

    > install.packages(“RecordLinkage”)
    WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

    https://cran.rstudio.com/bin/windows/Rtools/
    Installing package into ‘C:/Users/Documents/R/win-library/3.5’
    (as ‘lib’ is unspecified)

    There is a binary version available but the source version is later:
    binary source needs_compilation
    RecordLinkage 0.4-12 0.4-12.1 TRUE

    Io ho installato già Rtools ma non capisco perchè mi dica che non è installato!
    Se poi mando il comando library(RecordLinkage) mi escono i seguenti errori:

    > library(RecordLinkage)
    Carico il pacchetto richiesto: DBI
    Carico il pacchetto richiesto: RSQLite
    Error: package or namespace load failed for ‘RSQLite’:
    package ‘bit’ does not have a namespace
    Errore: package ‘RSQLite’ could not be loaded

    Effettivamente sono andata a controllare e nel pacchetto “bit” che trovo dentro il mio percorso “C:\Users\Documents\R\win-library\3.5\bit” non trovo il file NAMESPACE (nel pacchetto “RSQLite” invece è presente). Come posso risolvere questo problema? E nel caso in cui dovessi creare un NAMESPACE per “bit” come faccio a sapere cosa ci devo scrivere?

Stai vedendo 1 articolo (di 1 totali)

Devi essere loggato per rispondere a questa discussione.